Help Center > What are the Browser requirements for Brandkit?

Contents

What are the Browser requirements for Brandkit?

You'll need to use a supported web browser to log in to Brandkit.io or Brandkit.io powered brand kit. Brandkit uses modern web technology and will not work on older browsers.

Use the latest version of one of these browsers

  • Google Chrome (PC and Mac)
  • Internet Explorer (IE) 9 or higher (PC) - IE11 is preferred if possible.
  • Mozilla Firefox (PC and Mac)
  • Safari (Mac)
We don't support any beta versions of these browsers or alternative open source builds of them.
Make sure that cookies and JavaScript are enabled in your browser.

Using Brandkit on your mobile device

You can log in to Brandkit using your web browser on your mobile device. Some zooming may be required.
Brandkit will work on most devices and you'll get best results with the latest version of iOS Safari, Google Android Chrome, Mozilla Firefox, Internet Explorer or Opera Mini.

Contact Us

No call centres, just experienced knowledgeable people. :)